Cameras not recognized

  • Hi Antti,

    I understand you tried disabling your antivirus software. Do you have Norton 360? If so, please use Norton’s instructions at https://support.norton.com/sp/en/us/home/current/solutions/v126148153 to change your SafeCam settings so that either SafeCam is completely turned off or so that the “Access” setting for FarPlay is set to “Allow.” Then, quit and restart FarPlay.

    The video is the same in free mode and with a subscription. Using free mode doesn’t make any difference in getting video to work. Occasionally, there are some webcams/computers for which getting video to work requires more steps. Could you share the model of the camera you’re trying to use? To find your camera model, type “device manager” in the taskbar search box, click the Device Manager, and Look under “Cameras.”

    Thank you,
    David Liao


    Antti
    Participant

    Thank you David,

    I’m using BitDefender, not Norton, and I tried also launching FarPlay with it disabled.

    There are two webcams. An external Logitech HD Pro Webcam C920, and an internal VGA webcam original to the Acer Aspire A315-41 Laptop that I’m on. Neither is shown in FarPlay.

    Best

    Antti

    Thank you Antti, if you start OBS’s virtual camera and then start FarPlay, does OBS’s virtual camera appear in the list of cameras in FarPlay?

    Thank you,
    David Liao


    Antti
    Participant

    Hi!

    No, it doesn’t appear in the camera list. But it does appear as a camera in the Zoom App, for example.

    Thank you

    Antti

    Hi Antti,

    I have the same Logitech C920 camera and it works with no issues on HP ZBook running Windows 10. I’m sure the problem is the system configuration, not the device. The only possibly related system settings I’m aware of are those Camera permissions in Windows Privacy settings, you need to allow both general access to the camera and Desktop App access (another switch below the list of MS Store Apps). I assume they are both on based on what you wrote above. Normally FarPlay should appear in the list of Desktop apps.

    Besides that, it’s most likely some 3rd party security software that blocks the camera access to FarPlay. Unfortunately, we have not yet accumulated enough knowledge base about such issues (they are actually quite rare among our users). As David mentioned we saw some problems with Norton software, and that’s probably all we saw. FarPlay is a new and not widely known app yet, and many security software consider the apps they know nothing about as potentially harmful. There probably should be some configuration options for BitDefender (or maybe you have other security software installed? Notebook vendors sometimes add their own device specific security components for example). Just temporary disabling such apps might not be enough in some cases AFAIK, they might make permanent changes to windows configs and install permanently active hooks to windows security system. Also, sometimes you might need to reboot after disabling (or turning off) security protection components.

    Thanks,
    Anton


    Antti
    Participant

    Thank you Anton.

    The BitDefender I have is a free version, and it doesn’t include “Video and Audio protection”, which is feature the premium version would have.

    To me it simply seems that the camera won’t trigger with FarPlay somehow. 🤷‍♂️ All the other apps I’ve used so far show up as either Microsoft Store Apps or Desktop Apps in the Camera permissions list in Privacy Setting, but FarPlay does not.

    Camera drivers can’t be updated further. Zoom, Skype, OBS, and Google Meet via Brave browser all work well with the cameras, and I don’t recall ever receiving prompts to allow camera access from BitDefender, so for now I’m going to skip giving its uninstall and reinstall a go. Maybe later.

    Thank you for the help. I don’t see a solution that I could pull off for now, so I’ll look to FarPlay for audio and see for alternatives also.

    Best regards and good tidings with the business!

    Antti

    • This reply was modified 4 months ago by Antti.

    Dear Antti,

    Thank you for your reply. If you have interest, here are a couple more things that could be tried:

    1. Maybe we could look for and turn off a camera setting in some sort of control center app (not necessarily something like BitDefender or Norton). I was Googling, and, it seemed, in a support post (not related to FarPlay) someone had camera access issues on their PC because of the way BitDefender and their PC’s manufacturer-supplied control center interacted.
    2. We could look through the Windows registry for relevant entries.

    Thank you,
    David Liao

    Hi there David!

    Perhaps there was something to BitDefender after all.

    I tried to following, which is that I installed ManyCam, just to pick some webcam-enabled software I hadn’t tried. It installed without any prompts from Bitdefender or about the cameras. Both cameras worked right away, and the app got listed in Privacy Settings > Camera as a camera-enabled desktop app.

    I then tried uninstalling FarPlay, and reinstalling it from a new download.

    This time around the installer was picked up by Bitdefender for disinfection. That didn’t happen before, not did. I.e. it was not allowed to run.

    I disabled Bitdefender so the install went through without issue, but either camera nonetheless did not work, or show up.

    Thank you for your suggestions, they’re helpful, but I won’t put more time into figuring this out.

    Thank you anyway and take care!

    Antti

    Dear Antti,

    Thank you for your help troubleshooting. We released a bugfix version of FarPlay that solves occasional cases of cameras not being listed for Windows users. Version 1.2.7 is available at https://farplay.io/download/.

    Thank you,
    David Liao

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.