connection fails after 3-4 min

  • Thank you for your question. Connectivity in free mode is the same as with a subscription. In both cases, audio and video are sent directly between musicians (audio and video don’t pass through FarPlay servers). So, there’s no “overload issue” that would cause us to drop free sessions.

    1. Could you tell us the kinds of computers and audio equipment you and your friend use? Did equipment used change recently? On Windows, some audio devices have unreliable playback (switching to a different headset might help).
    2. Could you provide a session ID from one of the recent sessions where you had an issue? We can look through our logs to troubleshoot.

    Thank you,
    David Liao

    Thanks David
    So we are using Focusrite scarlett 4i4 / USB-C
    we’ve tried it a dozen times. here are some of our session IDs:
    2AB2C0
    3A6FAF
    I’m on W10 pro 64bit and my friend W11 home 64 bit
    We’re in Canada Quebec
    internet provider Bell Canada
    Thanks again!

    Thank you for the session IDs and equipment. For those sessions, Anton found that it seems there were audio issues on your side.

    Here are some ideas you can try.

    1. If the audio stops working, but you still see the other musician’s name, try clicking on FarPlay’s Devices > Headphones pull-down menu, clicking on No Audio, clicking the pull-down menu again, and then clicking on your desired audio device (“Focusrite USB ASIO” in the “ASIO devices” category, in your case). This resets your audio system without leaving the session altogether.
    2. Could you check that you’ve set up the audio the way explained in our QuickStart instructions (customized for Windows users using an external audio interface: https://farplay.io/quickstart/?os=win&audio=external)? These instructions make sure you select Focusrite’s low-latency ASIO drivers, rather than Windows’s built-in higher latency drivers, in FarPlay. (Using either set of drivers, the audio isn’t supposed to just stop, but we might as well make sure we’re using the best drivers).
    3. Please makes sure the computer is plugged into power and that “High Performance“/”Best Performance” is selected in power management settings (https://support.microsoft.com/en-us/windows/change-the-power-mode-for-your-windows-pc-c2aff038-22c9-f46d-5ca0-78696fdf2de8). Turn off power-saving on the USB controller you’re connecting the Scarlett to (https://www.soundonsound.com/forum/viewtopic.php?p=721131#p721131).
    4. If your Scarlett is connected to a USB hub, try connecting your Scarlett directly to a USB port on your PC.
    5. Have you tried changing the USB cable for the Scarlett? Is the USB cable snug? Try cleaning the USB port on the Scarlett (https://www.youtube.com/watch?v=AyXN3m8p6ls).
    6. When using FarPlay, please quit all other applications that could try to use audio/the Scarlett.

    Anton noted that you had seemingly successful sessions before and after the 2AB2C0 and 3A6FAF sessions. There are limitations to our logs. Were the sessions after the 2AB2C0 and 3A6FAF sessions successful?

    Thank you,
    David Liao

    • This reply was modified 1 month, 1 week ago by David Liao. Reason: Mostly formatting

    Hi David

    Yes, the sessions in between were successful but then again after some time (40-60 min) we have to stop and restart FARPLAY few times until we get both ends connected clearly.

    PS: we opted for the standard subscription. When it works it’s amazing very low latency!

    We had tried all of the above except the resetting of the Audio system. (I will try that next time)
    * We checked our RJ-45s / internet speed etc. all OK

    My last session ID was 6A9DAA.

    another issue I’m having is my partner sees my video but I can’t see neither him nor myself. Although my video works in other APPs but not in FARPLAY. tried reinstalling changing camera etc, but nothing.
    I’m browsing through the forum to see if any have similar issues 🙁

    thanks for the help and research!

    Greg

    Dear Greg,

    Thank you for your reply. Glad you’re getting amazing latency!

    I will bring your session ID (6A9DAA) to Anton.

    To get video to show up in the FarPlay Video window on your PC, try installing the latest drivers for your graphics card. You can download the drivers from the manufacturer’s website or update the drivers in Windows’s Device Manager. Could you share the model number of your computer?

    Thank you,
    David Liao

    Dear Greg,

    Anton checked the log for your session ID 6A9DAA. The log itself didn’t indicate any problems.

    If you run into a problem again, could you take and share a picture of your screen? I’m curious whether you see something like the example below. (Sometimes, when there is a problem with audio playback, the subpanel that shows you information about the remote musician says “waiting for remote audio” even while the level meter just above continues to flicker).

    Thank you,
    David Liao

    • This reply was modified 1 month, 1 week ago by David Liao.
    • This reply was modified 1 month, 1 week ago by David Liao.
    • This reply was modified 1 month, 1 week ago by David Liao.

    Hi David
    I’m using Dell Latitude E6420 8GB RAM CORE i5
    I tried like you said to reset the audio and it does work but stops after couple of minutes.
    So I have to keep going to Headphones under Devices and resetting it all the time.

    here are session IDs:
    2BAA24
    736642

    I tried to uninstall all drivers in question

    the video driver works after first start of FARPLAY. when I start it a second time it goes off dark again.

    I will see if a different PC will do the same.

    Thanks again!
    Greg

    Dear Greg,

    Thank you for the session IDs. Anton checked the logs. He sees audio restarts, but he doesn’t see indications of audio problems before the audio restarts.

    Thank you for your PC’s model. The processor is a bit older. If you’d like to keep testing with your Dell E6420, please, can you see what happens if you use your Focusrite’s device settings to change the ASIO Buffer Size to 64 or 128 samples (maybe even 256 samples)? These settings are less demanding on the computer than using ASIO Buffer Sizes of 16 or 32 samples. (To get to the Focusrite device settings, click ASIO Buffer Settings in FarPlay’s Preferences > General Options tab).

    Thank you,
    David Liao

    • This reply was modified 1 month ago by David Liao. Reason: Zoomed in on Focusrite settings window in screenshot (was small and hard-to-read)
    • This reply was modified 1 month ago by David Liao.
    • This reply was modified 1 month ago by David Liao.
Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.