standalone plugins and sound card

  • Hi Tony, In the standalone app, keep the Duet as your input, and switch the output from your Duet to BlackHole. In FarPlay, choose BlackHole as your microphone, and choose your Duet as your headphones. (I prefer to send the audio output from FarPlay directly to the audio interface, instead of through a virtual sound card to another app, to avoid some latency).

    If you want to use a mic that isn’t plugged into your Duet as a talkback mic, create an aggregate audio device that uses BlackHole and your talkback mic for inputs, and select this aggregate device as the microphone in FarPlay.

    • This reply was modified 1 month, 3 weeks ago by David Liao. Reason: Added "virtual sound card" to tags

    Dear David, I did the tests remotely with another guitarist, we both used a standalone plugin for our respective guitars and the result is this: we simply chose our own sound card as in and out of the standalone plugin (I used my duet 2 , my friend a Focusrite) and, by doing so, everything worked well….each of us could hear the sound of the other electric guitar coming out of our monitors.

    However, by choosing the black hole as the output of the standalone app, nothing could be heard (because the signal does not reach the monitors) and nothing reaches the farplay microphone.

    Hi Tony, if you don’t need talkback mics, then the way you and your partner tested without BlackHole (and with monitors) is fine.

    May I please see a screenshot showing what it looks like when you try to use BlackHole to ferry audio from your standalone app to FarPlay? In particular, I’d like to see the audio device settings in your standalone app, the Preferences > General Options settings in FarPlay and, if you’re using an aggregate device, the settings for your aggregate device in macOS’s Audio MIDI Setup. Thank you.

    Hi David, up to now I have carried out the tests remotely with two of my friends who have a Mac mini and do not have a webcam or microphone: consequently the interpersonal communication was carried out via WhatsApp, while for the instrumental part the system worked I described in previous emails.

    As far as my equipment is concerned, it consists of:
    Imac 27 inches mid 2011 on OS High Sierra – Apogee Duet 2 –
    I connect my guitar directly to the sound card so I have no problems with microphone feedback, I can use monitors and I don’t need headphones: until now due to the limited equipment of my partners I haven’t had the opportunity to test the functionality of the microphone and webcam integrated into the Mac…but certainly in the future there may be a problem of aggregate management of these two components integrated into the Mac with the external sound card.

    From this perspective, in the “audio midi” configuration of the Mac I tried to create some alternative solutions as shown in the attached screenshots:

    1) Duet USB in & out – setup I currently use and it works;
    2) only Black Hole output: with this configuration I lose the audio (nothing reaches the monitors) and nothing reaches the FarPlay microphone;
    3) Configuration carried out with a view to using the integrated microphone (for communicating) together with the external sound card (for playing)…;
    4)Configuration in which I try to combine Duet 2 and Black Hole on output;
    5) These are the solutions offered for the FarPlay microphone

    ….this is the last screenshot…

    …for completeness I attach the screen shot of the audio preferences in out of one of my standalone plugins

    • This reply was modified 1 month, 2 weeks ago by David Liao. Reason: (consolidated messages)
    Attachments:

    Attachments:

    Hi Tony, Thank you for the screenshots. To be clear, when you’re trying your strategy # 2 (trying to get audio from your standalone app through BlackHole to FarPlay), you need to select BlackHole as the microphone in FarPlay (in your screenshot, copied below, you have Duet USB selected as the microphone in FarPlay).

    With these settings, if you’d like to hear your local audio more easily, you’d probably want to raise your local monitor level (-13 dB in your screenshot).

    I selected black hole in the FarPlay microphone, but no sound comes out of the monitors and no audio signal arrives at FarPlay: anyway, thanks for the answer.
    Good work
    Tony

    Ok thank you. If it’s possible to get a single screenshot showing at the same time the standalone app’s audio settings and FarPlay’s Preferences > General Options window during a test where you’re trying to use BlackHole, but not audio is reaching FarPlay, I’d be interested to study it!

    I made a video for greater clarity
    but I can’t upload it because it exceeds the allowed size

    • This reply was modified 1 month, 2 weeks ago by David Liao. Reason: consolidate messages

    I think I have solved the problem: as you can see in screenshot 2, the black hole master stream bar is minus 49.14 db:
    raising the level to around -6db the signal became audible and was detected by the FarPlay monitor… I don’t know if I followed the correct procedure but it seems to work now…

    Attachments:

    That’s wonderful. Sorry, I didn’t see that at first. I think I usually just leave the Value and dB (Valore e dB) at 1.00 and 0.0 on both the Input (Ingresso) and Output (Uscita) tabs.

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.