Spikes in local latency

  • We received the following email.

    I keep having seemingly random spikes in my local latency before a guest has even arrived.

    Examples attached.

    – If I do nothing and just play, the latency stays pretty constant.
    – However, If I select Video, or Chat, or Invite ( different reactions different times ) the Local Latency goes haywire.

    If that number is supposed to just represent the signal path of my keyboard through audio interface, should the number be jumping around like that within FarPlay?

    thanks much

    Reply
    Spikes in local latency that large shouldn’t occur. Local latency estimates the time taken for audio to get from your keyboard to your computer and back out to your headphones. Large spikes in local latency occur when your computer is having trouble processing audio quickly enough.

    1. Make sure your Mac is plugged into power (not running on battery).
    2. Go to System Settings > Battery and make sure the settings for “On battery” and “On power adapter” are both “High Power” (not “Automatic” and not “Low Power”).
    3. Make sure nothing (papers, etc.) is blocking your Mac’s vents. Blow compressed air to clear dust out from the vents.
    4. Go to Applications > Utilities and open the Activity Monitor. Watch the CPU tab. Do spikes in local latency coincide with an application (FarPlay or otherwise) having a high “% CPU”?
    5. Try quitting other applications as much as possible (particularly applications that use audio). When looking for apps to quit, remember that some apps don’t appear in the dock (example: DropBox updater).
    6. If, for example, turning off Malwarebytes fixes the problem, but you’d prefer not to completely quit out of Malwarebytes, see whether turning off just the real-time protection in Malwarebytes works too.
    7. It’s not common, but spikes in latency have been known to result from a video driver conflict. Try disconnecting all unnecessary accessories (e.g. webcams). Do you have a video driver app called quick cam?

    Thank you,
    David Liao

    • This topic was modified 4 months, 2 weeks ago by David Liao.
    • This topic was modified 4 months, 2 weeks ago by David Liao.
    • This topic was modified 4 months, 2 weeks ago by David Liao.
    • This topic was modified 4 months, 2 weeks ago by David Liao.
    • This topic was modified 4 months, 2 weeks ago by David Liao. Reason: formatting
  • Thanks, David. You’re awesome.

    Short answer : It appears the issue was with my USB HD Camera! I guess it never occurred to me that that latency could be affected so easily by the CPU drain from an external device.

    I just wired my iphone to the laptop and using that as webcam now, with no more spikes. 🙂

    Prior to trying that, I also cleared out GB’s of files from my SSD and did general maintenance with Clean My Mac, so that will be better in the long run too, I think.

    Can’t wait to try a new FP Session!

    -Ben

    p.s.fyi I think the “High Performance” Battery setting you mentioned may be just for M1,M2, etc. devices.(?) I’m on a 15″ Retina MBPro. That said, it seems that my battery health does say “Service Recommended”.

    Dear Ben,

    So happy the problem is solved! Thank you for letting us know. Would you be able to share the model of your USB HD Camera?

    Oh yes, the “High-Power” setting is for “14-inch MacBook Pro models with M3 Max and 16-inch MacBook Pro models with M1, M2 or M3 Max” processors https://support.apple.com/en-us/HT212852.

    Thank you,
    David Liao

    • This reply was modified 4 months, 1 week ago by David Liao.
    • This reply was modified 4 months, 1 week ago by David Liao. Reason: Fixed listing of MacBook Pro models that have the High-Power setting

    Dear Ben, I have a MacBook 14″ M1. My Battery setting states Low Power Mode with a a drop down menue Never, Always, Only On Battery , Only On Power adapter.

    Also, I sometimes have an upload speed problem even on my Ethernet port. Will turning off the video feed help in that circumstance?

    Thankls,

    Peter Thomsen

    Dear Peter,

    In the “Low Power Mode” drop-down menu, choose Never.

    Yes, turning off video will help by reducing the bandwidth FarPlay uses. You can also continue to use video with reduced bandwidth by using the instructions for adjusting “Your max outgoing bandwidth” at https://farplay.io/video/#videosettings.

    I used a copy of your comment about the upload speed problem to start a new thread with recommendations at https://farplay.io/forum/topic/upload-speed-problem-on-ethernet-port/.

    Thank you,
    David Liao

    • This reply was modified 4 months, 1 week ago by David Liao.
    • This reply was modified 4 months, 1 week ago by David Liao.
Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.